iommu subsystem · Maintained
Maintainers
- M Joerg Roedel <joro@8bytes.org>
- M Will Deacon <will@kernel.org>
- R Robin Murphy <robin.murphy@arm.com>
Paths
- F
Documentation/devicetree/bindings/iommu/ - F
drivers/iommu/ - F
include/linux/iommu.h - F
include/linux/iova.h - F
include/linux/of_iommu.h - F
rust/kernel/iommu/
Last 30 days
Active reviewers (last 30 days)
-
Robin Murphy <robin.murphy@arm.com>
2 attestations (2 Suggested-by) · last on 2026-06-04
Recent patches
Most-recent 30 patches in this subsystem on virtualization (capped at 30), ordered by date desc.
-
COLD27d
[PATCH 2/2] iommu/virtio: Avoid using the list iterator past the loop in viommu_add_resv_mem()
2026-06-04 · Maoyi Xie <hidden> -
COLD27d
[PATCH 1/2] iommu: Avoid using the list iterator past the loop in iommu_insert_resv_region()
2026-06-04 · Maoyi Xie <hidden> -
STALE90d
REVIEWED: 5 (5M) [PATCH v2] iommu: Always fill in gather when unmapping
2026-04-02 · Jason Gunthorpe <jgg@nvidia.com> -
STALE84d
Re: [PATCH] iommu: Always fill in gather when unmapping
2026-04-01 · Robin Murphy <robin.murphy@arm.com> -
STALE84d
[PATCH] iommu: Always fill in gather when unmapping
2026-03-31 · Jason Gunthorpe <jgg@nvidia.com> -
STALE103d
LANDED [PATCH v3 6/8] iommu/dma: add support for DMA_ATTR_REQUIRE_COHERENT attribute
2026-03-16 · Leon Romanovsky <leon@kernel.org> -
STALE111d
[PATCH v2 6/8] iommu/dma: add support for DMA_ATTR_REQUIRE_COHERENT attribute
2026-03-11 · Leon Romanovsky <leon@kernel.org> -
STALE127d
LANDED: 11 (11M) [PATCH v7 8/8] iommufd: Add dma_buf_pin()
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE127d
REVIEWED: 3 (3M) [PATCH v7 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE127d
REVIEWED: 3 (3M) [PATCH v7 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE152d
REVIEWED: 11 (11M) [PATCH v6 8/8] iommufd: Add dma_buf_pin()
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE152d
REVIEWED: 3 (3M) [PATCH v6 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE152d
REVIEWED: 3 (3M) [PATCH v6 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE149d
REVIEWED: 3 (3M) [PATCH v5 8/8] iommufd: Add dma_buf_pin()
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE149d
LANDED: 3 (3M) [PATCH v5 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE149d
LANDED [PATCH v5 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE161d
REVIEWED: 3 (3M) [PATCH v4 6/8] iommufd: Pin dma-buf importer for revoke semantics
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE161d
[PATCH v4 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE161d
REVIEWED: 3 (3M) [PATCH v4 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE159d
[PATCH v3 5/7] iommufd: Pin dma-buf importer for revoke semantics
2026-01-20 · Leon Romanovsky <leon@kernel.org> -
STALE159d
REVIEWED: 3 (3M) [PATCH v3 1/7] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-20 · Leon Romanovsky <leon@kernel.org> -
STALE162d
[PATCH v2 3/4] iommufd: Require DMABUF revoke semantics
2026-01-18 · Leon Romanovsky <leon@kernel.org> -
STALE162d
[PATCH v2 1/4] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-18 · Leon Romanovsky <leon@kernel.org> -
STALE195d
REVIEWED: 8 (8M) [PATCH v2 6/6] iommu: Pass in old domain to attach_dev callback functions
2025-10-23 · Nicolin Chen <hidden> -
STALE195d
REVIEWED: 6 (6M) [PATCH v2 5/6] iommu: Do not revert set_domain for the last gdev
2025-10-23 · Nicolin Chen <hidden> -
STALE195d
REVIEWED: 6 (6M) [PATCH v2 4/6] iommu/amd: Set release_domain to blocked_domain
2025-10-23 · Nicolin Chen <hidden> -
STALE195d
REVIEWED: 14 (14M) [PATCH v2 3/6] iommu/exynos-iommu: Set release_domain to exynos_identity_domain
2025-10-23 · Nicolin Chen <hidden> -
STALE195d
REVIEWED: 6 (6M) [PATCH v2 2/6] iommu/arm-smmu-v3: Set release_domain to arm_smmu_blocked_domain
2025-10-23 · Nicolin Chen <hidden> -
STALE195d
[PATCH v2 1/6] iommu: Generic support for RMRs during device release
2025-10-23 · Nicolin Chen <hidden> -
STALE236d
[PATCH v1 19/20] iommu/virtio-iommu: Implement viommu_domain_test_dev
2025-10-13 · Nicolin Chen <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE161d
[PATCH v4 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE111d
[PATCH v2 6/8] iommu/dma: add support for DMA_ATTR_REQUIRE_COHERENT attribute
2026-03-11 · Leon Romanovsky <leon@kernel.org> -
STALE103d
LANDED [PATCH v3 6/8] iommu/dma: add support for DMA_ATTR_REQUIRE_COHERENT attribute
2026-03-16 · Leon Romanovsky <leon@kernel.org>